Friday, August 31, 2018

Load Balance 2 ISP di Mikrotik Dengan Metode PCC

Pada kesempatan ini sambilbaca.com akan memberikan tutorial bagaimana menggabungkan dua ISP berbeda dengan menggunakan mikrotik.
Umumnya Mikrotik banyak kita gunakan sebagai media pembantu bandwidth management jaringan internet kita. load balancing adalah salah satu fitur terbaik Mikrotik yang juga banya di gunakan di berbagai usaha-usaha jaringan.

Load Balance 2 ISP Dengan Metode PCC

PCC adalah kependekan dari Per Connection Classifier, Kenapa PCC.? berdasarkan pengalaman dilapangan menggunakan metode PCC jauh lebih optimal dibandingkan dengan metode load balance lainnya.

Load balance pada mikrotik adalah teknik untuk mendistribusikan beban trafik pada dua atau lebih jalur koneksi secara seimbang, agar trafik dapat berjalan optimal, memaksimalkan throughput, memperkecil waktu tanggap dan menghindari overload pada salah satu jalur koneksi.

Metode PCC ini juga dapat diterapkan lebih dari 2 ISP, tapi pada kesempatan ini saya coba hanya 2 ISP saja.

Langkah-Langkah Konfigurasi Load Balance PCC

  • Buka Winbox kemudian login ke mikrotik anda
  • Copy script di bawah ini kemudian paste ke dalam text editor seperti notepad++, edit nama interface dan sesuaikan dengan kondisi pada mikrotik anda lalu copy script yang sudah di edit kemudian masukan ke “new terminal” winbox.
  • Membuat penanda koneksi keluar masuk dari masing-masing ISP
/ip firewall mangle>
add chain=prerouting action=mark-connection new-connection-mark=conn-WanA passthrough=yes connection-mark=no-mark in-interface=ether1-inet1 log=no log-prefix="" 
add chain=output action=mark-routing new-routing-mark=lewat-ISP-A passthrough=yes connection-mark=conn-WanA log=no log-prefix="" 
add chain=prerouting action=mark-connection new-connection-mark=conn-WanB passthrough=yes connection-mark=no-mark in-interface=ether2-inet2 log=no log-prefix="" 
add chain=output action=mark-routing new-routing-mark=lewat-ISP-B passthrough=yes connection-mark=conn-WanB log=no log-prefix="" 
Fungsi script di atas adalah agar paket yang sudah melewati ISP-A maka pulang pergi harus melewati ISP-A, begitu juga sebaliknya dengan paket yang melewati ISP-B.
  • Membuat klasifikasi koneksi yang dilewati lokal melalui kedua ISP
/ip firewall mangle>
add chain=prerouting comment="Per Connection Classifier" action=mark-connection new-connection-mark=conn-LanA passthrough=yes protocol=tcp src-address=10.20.30.2 in-interface=ether3 dst-port=80,8080,443 per-connection-classifier=src-address-and-port:2/0 log=no log-prefix=""
add chain=prerouting action=mark-routing new-routing-mark=lewat-ISP-A passthrough=no connection-mark=conn-LanA in-interface=ether3 log=no log-prefix=""
add chain=prerouting action=mark-connection new-connection-mark=conn-LanB passthrough=yes protocol=tcp src-address=10.20.30.2 in-interface=ether3 dst-port=80,8080,443 per-connection-classifier=src-address-and-port:2/1 log=no log-prefix=""
add chain=prerouting action=mark-routing new-routing-mark=lewat-ISP-B passthrough=no connection-mark=conn-LanB in-interface=ether3 log=no log-prefix="" 
Fungsi Script di atas adalah untuk mengklasifikasikan koneksi dari local menuju ke internet melalui ISP-A ataupun ISP-B.
  • Membuat Load Balancing dari kedua ISP menuju koneksi Local
/ip firewall mangle>
add chain=prerouting comment="Per Address Load Balance" action=mark-connection new-connection-mark=conn-LanA passthrough=yes src-address=10.20.30.2 in-interface=ether3 per-connection-classifier=both-addresses:2/0 log=no log-prefix="" 
add chain=prerouting action=mark-routing new-routing-mark=lewat-ISP-A passthrough=no connection-mark=conn-LanA in-interface=ether3 log=no log-prefix="" 
add chain=prerouting action=mark-connection new-connection-mark=conn-LanB passthrough=yes src-address=10.20.30.2 in-interface=ether3 per-connection-classifier=both-addresses:2/1 log=no log-prefix="" 
add chain=prerouting action=mark-routing new-routing-mark=lewat-ISP-B passthrough=no connection-mark=conn-LanB in-interface=ether3 log=no log-prefix=""
Fungsi Script di atas adalah untuk melakukan balancing diantara kedua ISP-A dan ISP-B.
  • Membuat routing menuju perangkat modem dari masing-masing kedua ISP
/ip route >
add distance=1 gateway=192.168.0.1 routing-mark=lewat-ISP-A
add distance=2 gateway=192.168.2.1 routing-mark=lewat-ISP-B
Fungsi Script di atas adalah untuk membuat routing ke arah perangkat modem dari masing IPS-A dan ISP-B

Keterangan :

  • ether3 adalah interface yang terhubung ke lokal
  • ether1-inet1 adalah interface yang terhubung ISP A
  • ether1-inet2 adalah interface yang terhubung ISP B
  • 10.20.30.2 adalah IP lokal
  • 192.168.0.1 adalah gateway ISP A
  • 192.168.2.1 adalah gateway ISP B
Load Balance 2 ISP di Mikrotik Dengan Metode PCC
Load Balance 2 ISP di Mikrotik Dengan Metode PCC

Semoga tutorial ini dapat bermanfaat, dan terima kasih telah berkunjung. jika ada yang ingin ditambahkan atau kekeliruan saya memberikan informsi mohon untuk menambahkan di kolom komentar.

reff, dokter-squid

Comments

Tinggalkan Komentar Anda dibawah ini :
Berkomentarlah dengan baik dan sopan.
EmoticonEmoticon